Troubleshooting

Utility Says No Devices Connected Even After Device is Connected

Issue 1

You have connected your Performance Monitor to your computer with the USB cable, but the Concept2 Utility still displays "No devices connected" in the upper right corner.

Resolution

This indicates that the Concept2 Utility cannot see the PM. Take the following steps.

  1. Shut down any other PM software (like Rowpro or Polar WebSync) that you have running. Note: Polar WebSync, in particular, prevents the PM from communicating with the Concept2 Utility. Additionally, Dell Stage and Fingertapps software (which is included on some Dell Touch screens) have also prevented communication between the PM and the Concept2 Utility.
  2. Unplug the PM.
  3. Reboot your computer.
  4. After reboot, run only the Concept2 Utility.
  5. Turn on your computer's volume.
  6. Plug the PM back into the computer, taking care to plug the USB cable in correctly. Your computer should make a ding-ding sound whenever the PM is plugged in or unplugged. If you did not hear this sound and the "No devices connected" message persists:
    1. Try plugging the USB into a different port on your computer.
    2. If the problem persists, try using a different USB cable. (Any USB cable will work; it does not have to be one from Concept2.) If the new cable works, the old cable is faulty.
    3. If using a different cable does not resolve the issue, remove the USB cable and the battery pack (PM4 only) or batteries from the monitor, and leave them out for 30 minutes. Then, reinstall the batteries/battery pack, and the USB cable, and try again.
    4. If still no success, the USB port on your computer may be bad. You can test this by trying another computer. Otherwise, contact Concept2 for additional support.

Issue 2

You are using a Performance Monitor to read your LogCard, the PM is properly connected to your computer, but the Concept2 Utility still displays "No devices connected" in the upper right corner.

Resolution

Make sure the LogCard is inserted completely and in the proper orientation in the PM. The arrow side of the card should be facing you, and the arrow should be pointing into the monitor. When properly inserted, the arrow is no longer visible.

Issue 3

You are using a card reader to read your LogCard, the card reader is connected to your computer via the USB cable, but the Concept2 Utility still displays "No devices connected" in the upper right corner.

Resolution (For Athena Card Readers Only)

Update the driver for the Athena Card Reader:

  1. Connect your card reader to your computer.
  2. Connect to the internet.
  3. On your computer, access the Device Manager:
    1. Right-click Computer.
    2. Click Manage.
    3. Click Device Manager.
  4. In the list of devices, double-click SmartCard Readers.
  5. Follow the instructions for updating the driver from the internet.

Resolution (For OmniKey Card Readers Only)

Ensure that the OmniKey driver is installed properly. See Installing the OmniKey Card Reader for more information.